Featured Post

Beogram 4002: Restoration of DC Motor Video Published - Check It Out!

By popular request (really, I got quite a few emails about this!...;-), I finally completed my Beogram DC motor restoration video! It demon...

Monday, October 15, 2012

Beomaster 8000 Suddenly Goes into Standby Mode

The Beomaster 8000 is on the bench again. After about two weeks of happy service in the living room after 'completing' my restoration, out of a sudden it went into standby. Turned it on again...half an hour later: Standby! Not great. Tried it a few more times....Standby! And again!. I swapped it out with Beomaster 8000-2 (it is like with classic cars...one best has two if one is supposed to run at all times...;-), and opened it up. It turned out that the standby pin (#14 on IC4 - the microprocessor responsible for the radio, volume and startup) occasionally disconnected from the power supply causing the Beomaster to go into standby. This becomes evident by a larger-than-0V voltage (~3.5-4V) at pin 7 on P76 on the microprocessor board (#9). I traced the problem to a bad via on the board. Resoldering the via between P76-7 and pin 14 of the processor solved the problem. Here is a picture:



I resoldered all three vias above the microprocessor (to the right of the C97 label) for good measure. This is done best by simply putting a dab of flux paste on each via, and briefly reheating them with the soldering iron (340C). Use the usual precautions against ESD if you do this in a dry-air environment...the microprocessors are hard to find...;-).

No comments:

Post a Comment

Comments and suggestions are welcome!